FlexMobile werkt op Android of op iOS van iPhone. De iPhone-versie is compatibel met iPhone 3GS, iPhone 4, iPhone 4s en iPhone 5. De iPhone app is geoptimaaliseerd voor de iPhone4 en iPhone5 en vereist iOS 5.1 of nieuwer. De Android-versie is geschikt voor Android firmware versies vanaf 2.3. FlexMobile is compatibel met de meeste toestellen van Samsung, HTC, Sony, etc.